Uploaded image for project: 'PUBLIC - Liferay Alloy UI'
  1. PUBLIC - Liferay Alloy UI
  2. AUI-1014

AUI Tree | Existing child nodes of the dropNode are not loaded after Drag&Drop. Only dragNode is displayed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.x, 1.5.x, 1.0.x
    • Fix Version/s: 2.0.x, 1.5.x, 1.0.x, 1.5.2.3
    • Component/s: Tree
    • Labels:

      Description

      1- Download "index.html" & override the existing file in alloy-ui/demos/tree with this one
      2- Copy the whole "tree" folder under for example TOMCAT_HOME/webapps
      3- Start tomcat
      4- In browser, navigate to http://yourHost:port/tree/index.html

      5- Note that both "Drag" and "Drop" are loaded correctly
      6- Expand "Drop" >>> Child nodes get loaded correctly

      7- Refresh the page
      8- D&D "Drag" onto "Drop"

      Result Only "Drag" node is displayed as child, existing children are missing

      Gist for index.html: https://gist.github.com/lipusz/0f9280029b303d469037#file-index-html

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  6 years, 7 weeks ago

                  Packages

                  Version Package
                  2.0.x
                  1.5.x
                  1.0.x
                  1.5.2.3