Uploaded image for project: 'PUBLIC - Liferay Alloy UI'
  1. PUBLIC - Liferay Alloy UI
  2. AUI-2025

Provide Support for Swift 2.0

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None

      Description

      Apple recently released Xcode 7. You are more or less forced to use it if you want to develop for iOS 9 or deploy on a Device running iOS9.

      Xcode 7 enforces Swift 2.0 and does not allow building projects including the Screens framework, which currently is written in Swift 1.2.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                4 years, 5 weeks, 2 days ago

                Packages

                Version Package