Uploaded image for project: 'PUBLIC - Liferay BLADE'
  1. PUBLIC - Liferay BLADE
  2. BLADE-519

[blade convert] does not consider new spring-webmvc/webmvc-portlet dependencies that are now required

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.9.0
    • Fix Version/s: 4.0.0
    • Component/s: blade-cli
    • Labels:

      Description

      Spring portlets in 6.2, those had spring-web.jar dependency, but in 7.1 or spring 4.x, you need to specify additional dependencies to

      spring-webmvc
      spring-webmvc-portlet
      

      The convert command should take this into consideration and add these dependencies for them.

        Attachments

          Activity

            People

            Assignee:
            simon.jiang Simon Jiang
            Reporter:
            gregory.amerson Gregory Amerson
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                4.0.0