Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.9.2
    • Fix Version/s: master
    • Component/s: blade-cli
    • Labels:
      None

      Description

      blade sh is not working on a clean installation of blade-cli 3.9.2 (uninstalled previous versions)

      I get this error:

      java.lang.NoClassDefFoundError: com/liferay/gogo/shell/client/GogoShellClient
      	at com.liferay.blade.cli.command.ShellCommand._executeCommand(ShellCommand.java:62)
      	at com.liferay.blade.cli.command.ShellCommand.execute(ShellCommand.java:49)
      	at com.liferay.blade.cli.BladeCLI._runCommand(BladeCLI.java:1188)
      	at com.liferay.blade.cli.BladeCLI.runCommand(BladeCLI.java:591)
      	at com.liferay.blade.cli.BladeCLI.run(BladeCLI.java:435)
      	at com.liferay.blade.cli.BladeCLI.main(BladeCLI.java:131)
      Caused by: java.lang.ClassNotFoundException: com.liferay.gogo.shell.client.GogoShellClient
      	at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	... 6 more
      

       

        Attachments

          Activity

            People

            Assignee:
            lawrence.lee Lawrence Lee
            Reporter:
            rocco.germinario Rocco Germinario
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                master