Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.0
    • Fix Version/s: None
    • Component/s: blade-cli
    • Labels:
      None

      Description

       

      Cannot create a liferay 7.3 community with blade:

      $ blade init -v "7.3"
      Invalid syntax for version: 7.3.1-1
      java.lang.IllegalArgumentException: Invalid syntax for version: 7.3.1-1
      

      By leaving the -v option empty:

      $ blade init
      Error: The command init is missing required parameters.
      The following option is required: [--liferay-version | -v] The Liferay product to target. Typing "more" will show all product versions.
      1: dxp-7.2-sp1
      2: dxp-7.1-sp4
      3: dxp-7.0-sp13
      4: portal-7.3-ga3
      5: portal-7.2-ga2
      6: portal-7.1-ga4
      7: portal-7.0-ga7
      8: commerce-2.0.7-7.2
      > 4
      Invalid syntax for version: 7.3.2-1
      java.lang.IllegalArgumentException: Invalid syntax for version: 7.3.2-1
      

      Blade version:

      4.0.0.202007090048

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            enrico.costanzi enrico.costanzi
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package