Uploaded image for project: 'PUBLIC - Liferay Commerce'
  1. PUBLIC - Liferay Commerce
  2. COMMERCE-6386

Unresolved requirement: Import-Package: com.liferay.commerce.account.service

Details

    • Critical

    Description

      For lpkg-hot-deployment-jdk8/0 batch:

      [exec] 02:38:25,138 INFO  [Start Level: Equinox Container: c431b7cf-c330-4913-b155-eca4ae292ee3][BundleStartStopLogger:46] STARTED Liferay Commerce Connector to PunchOut2Go - API_1.0.0 [1280]
           [exec] 02:38:25,362 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:46] STARTED com.liferay.commerce.punchout.lang_3.0.15 [1285]
           [exec] 02:38:25,363 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:46] STARTED com.liferay.commerce.punchout.oauth2.provider.rest_3.0.15 [1286]
           [exec] 02:38:25,374 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:46] STARTED Liferay Commerce Connector to PunchOut2Go - Impl_1.0.0 [1284]
           [exec] 02:38:25,383 ERROR [fileinstall-directory-watcher][LPKGArtifactInstaller:170] Rollback bundle installation for [com.liferay.headless.commerce.punchout.impl_3.0.12 [1290], com.liferay.commerce.punchout.web_3.0.11 [1289], com.liferay.commerce.punchout.lang_3.0.15 [1285], com.liferay.commerce.punchout.service_3.0.10 [1288], com.liferay.commerce.punchout.portal.security.auto.login_3.0.15 [1287], com.liferay.commerce.punchout.oauth2.provider.rest_3.0.15 [1286]]
           [exec] org.osgi.framework.BundleException: Could not resolve module: com.liferay.headless.commerce.punchout.impl [1290]
           [exec]   Unresolved requirement: Import-Package: com.liferay.commerce.account.service; version="[3.0.0,99.0.0)"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:428)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:447)
           [exec] 	at com.liferay.osgi.util.bundle.BundleStartLevelUtil._startBundle(BundleStartLevelUtil.java:70)
           [exec] 	at com.liferay.osgi.util.bundle.BundleStartLevelUtil.setStartLevelAndStart(BundleStartLevelUtil.java:50)
           [exec] 	at com.liferay.portal.lpkg.deployer.internal.LPKGArtifactInstaller._batchInstall(LPKGArtifactInstaller.java:156)
           [exec] 	at com.liferay.portal.lpkg.deployer.internal.LPKGArtifactInstaller.transformURL(LPKGArtifactInstaller.java:98)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._install(DirectoryWatcher.java:648)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._install(DirectoryWatcher.java:683)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._process(DirectoryWatcher.java:981)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher.run(DirectoryWatcher.java:265)
           [exec] 02:38:25,388 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:49] STOPPED Liferay Commerce Connector to PunchOut2Go - Impl_1.0.0 [1284]
           [exec] 02:38:25,419 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:49] STOPPED com.liferay.commerce.punchout.lang_3.0.15 [1285]
           [exec] 02:38:25,444 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:49] STOPPED com.liferay.commerce.punchout.oauth2.provider.rest_3.0.15 [1286]
           [exec] 02:38:25,460 ERROR [fileinstall-directory-watcher][LPKGArtifactInstaller:170] Rollback bundle installation for [com.liferay.commerce.punchout.oauth2.provider.api_4.1.1 [1282], com.liferay.commerce.punchout.api_4.0.11 [1281], com.liferay.headless.commerce.punchout.api_4.1.3 [1283]]
           [exec] org.osgi.framework.BundleException: Could not resolve module: com.liferay.commerce.punchout.api [1281]
           [exec]   Unresolved requirement: Import-Package: com.liferay.commerce.model; version="[6.0.0,7.0.0)"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:428)
           [exec] 	at org.eclipse.osgi.internal.framework.EquinoxBundle.start(EquinoxBundle.java:447)
           [exec] 	at com.liferay.osgi.util.bundle.BundleStartLevelUtil._startBundle(BundleStartLevelUtil.java:70)
           [exec] 	at com.liferay.osgi.util.bundle.BundleStartLevelUtil.setStartLevelAndStart(BundleStartLevelUtil.java:50)
           [exec] 	at com.liferay.portal.lpkg.deployer.internal.LPKGArtifactInstaller._batchInstall(LPKGArtifactInstaller.java:156)
           [exec] 	at com.liferay.portal.lpkg.deployer.internal.LPKGArtifactInstaller.transformURL(LPKGArtifactInstaller.java:98)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._install(DirectoryWatcher.java:648)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._install(DirectoryWatcher.java:683)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher._process(DirectoryWatcher.java:981)
           [exec] 	at com.liferay.portal.file.install.internal.DirectoryWatcher.run(DirectoryWatcher.java:265)
           [exec] 02:38:25,460 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:49] STOPPED Liferay Commerce Connector to PunchOut2Go - API_1.0.0 [1280]
           [exec] 02:38:25,462 INFO  [fileinstall-directory-watcher][BundleStartStopLogger:49] STOPPED com.liferay.commerce.punchout.oauth2.provider.api_4.1.1 [1282]
      

      Attachments

        Activity

          People

            ivica.cardic Ivica Cardic
            felix.zhang Felix Zhang
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Packages

                Version Package
                7.3.X