Uploaded image for project: 'PUBLIC - Liferay Commerce'
  1. PUBLIC - Liferay Commerce
  2. COMMERCE-8330

Search is not properly working on Channels under Products -> Visibility -> Add New Channel

Details

    Description

      Steps to Reproduce:

      1) Select any Product and go to Visibility.
      2) Enable Channel Filter and try to add a new channel (clicking on + icon)
      3) Search any channel by using a keyword from it works fine but if the channel name has a _ it does not search for the pattern coming after _

      So for example if there are channels created :
      a) Outlet_1001
      b) Outlet_1002
      c) Outlet_2001

      Then if we search with keywords:
      1- Outlet - It works fine
      2- Outlet_1002 works fine
      3- 100 or 1001- It does not work and no result is returned

      Expected: Search should display filtered results.
      Actual: Search is not working with pattern after _

      Branch- Commit: 76a0d7391fa951373b176bc4ea0c28ab61d31b7c- Issue Reproduced

      Master- Commit: fcbb1a373eba2dcd64365307d8422d5708673f38- Issue Reproduced

      Attachments

        Activity

          People

            brian.chan Brian Chan
            il.kim Brian I. Kim
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Packages

                Version Package
                7.3.X
                7.4.X
                7.4 DXP U20