PUBLIC - Liferay Faces
  1. PUBLIC - Liferay Faces
  2. FACES-1171

"User Session Expired" error displayed in browser for icefaces3-ipc-ajax-push-portlet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-ga1, 3.1.0-ga1
    • Fix Version/s: 3.0.0-ga1, 3.1.0-ga1
    • Component/s: Demos
    • Labels:
      None
    • Similar Issues:
      Show 5 results 

      Description

      The initial Ajax Push IPC seems to be working on the first click, but subsequent clicks are causing the "User Session Expired" error to be displayed in the browser.

        Issue Links

          Activity

          Neil Griffin added a comment -

          @Deryk: I tested the icefaces3-ipc-ajax-push-portlet with ICEfaces 3.1.0.RC1 and Ajax Push worked OK.

          William Palmer added a comment -

          Session expiry bug - webapp allowing bug to be reproduced easily

          William Palmer added a comment -

          icefaces3basic.war
          Basically just contains a couple of simple portlets and an event manager to send messages between them.

          Deryk Sinotte added a comment -

          I ran the icefaces3basic.war and can reproduce the "Session Expired" issue. I can also verify that the problem is caused by the ViewState problem noted and fixed in the JIRA from our system: http://jira.icesoft.org/browse/ICE-8149. If I interpret the results of your testing accurately, it would appear that a regression was introduced in between the release of the open source version of ICEfaces 3.0.0 and ICEfaces EE 3.0.0 which is causing the behaviour. The fix has been applied to the upcoming release (3.1.0) as well as the 3.0.x maintenance branch so will be in the next EE patch release (EE-3.0.0.GA_P01) as well. If you are an EE customer and you need a solution sooner than that, you should go through the ICEfaces Product Support channels to discuss the options.

          William Palmer added a comment -

          Hi Deryk, thanks for the information. We'll await the patch release.


            People

            • Assignee:
              Neil Griffin
              Reporter:
              Neil Griffin
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Structure Helper Panel