Uploaded image for project: 'PUBLIC - Liferay Faces'
  1. PUBLIC - Liferay Faces
  2. FACES-2716

Liferay Faces projects with compatability for Liferay 7 depend on javax.el 2.0.0 rather than the provided version of 3.0.0

    Details

      Description

      {markdown}
      Liferay 7 provides *`javax.el-api.jar`* version `3.0.0`. However, Liferay Faces projects compatible with Liferay 7 are built with a dependency on *`javax.el-api.jar`* version `2.2.1`. Bridge-Ext 5 and 6 and Portal 3 should simply be upgraded to *`javax.el-api.jar`* version `3.0.0`. However, Bridge-Impl 4 and 5 must use profiles to select the correct version at build time since Bridge-Impl 4 supports Liferay 6.2, Liferay 7.0, and Pluto 2 and Bridge-Impl 5 is targeting Pluto 3.

      *Note:* In order to remain compatible with Pluto 2, all other projects must continue to depend on *`javax.el-api.jar`* version `2.2.1`. Since the dependency is `<scope>provided</scope>` and *`javax.el-api.jar`* `3.0.0` is backwards compatible, those artifacts will still work with *`javax.el-api.jar`* `3.0.0`.{markdown}

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Packages

                Version Package
                portal-3.0.0
                bridge-ext-5.0.0
                bridge-impl-4.0.0
                bridge-impl-5.0.0
                bridge-ext-6.0.0