Uploaded image for project: 'PUBLIC - Liferay Faces'
  1. PUBLIC - Liferay Faces
  2. FACES-3476

Adjust the Liferay Faces Bridge Ext version scheme in order to accommodate Liferay Portal 7.3 + Portlet 2.0 + JSF 2.2

Details

    Description

      Due to major version breaking changes in the com.liferay.portal.kernel.jar API dependency for Liferay Portal 7.3, it is necessary to adjust the Liferay Faces Bridge Ext version scheme according to the following:

      Old Version New Version New Usage
      N/A com.liferay.faces.bridge.ext-6.x Liferay Portal 7.2 and 7.3 / Portlet 2.0 / JSF 2.2
      com.liferay.faces.bridge.ext-6.x com.liferay.faces.bridge.ext-7.x Liferay Portal 7.2+ / Portlet 2.0 / JSF 2.2
      com.liferay.faces.bridge.ext-7.x com.liferay.faces.bridge.ext-8.x Liferay Portal 7.2+ / Portlet 2.0 / JSF 2.3

      Attachments

        Activity

          People

            neil.griffin Neil Griffin
            neil.griffin Neil Griffin
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Packages

                Version Package
                bridge-ext-7.0.0
                bridge-ext-8.0.0
                bridge-ext-6.0.0