Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-1029

liferay-ide trunk unable to build due to missing org.slf4j dependency

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.0.0
    • 2.0.0 M1
    • Releng, Releng > Build
    • None

    Description

      [INFO] Cannot complete the request. Generating details.
      [INFO] Cannot complete the request. Generating details.
      [INFO]

      {osgi.ws=win32, osgi.os=win32, osgi.arch=x86_64, org.eclipse.update.install.features=true}

      [ERROR] Cannot resolve project dependencies:
      [ERROR] Software being installed: com.liferay.ide.maven.core 2.0.0.qualifier
      [ERROR] Missing requirement: org.eclipse.m2e.core.ui 1.4.0.20130525-0310 requires 'bundle org.slf4j.api 1.6.2' but it could not be found
      [ERROR] Missing requirement: org.eclipse.m2e.core.ui 1.4.0.20130601-0317 requires 'bundle org.slf4j.api 1.6.2' but it could not be found
      [ERROR] Missing requirement: org.eclipse.m2e.jdt 1.4.0.20130601-0317 requires 'bundle org.slf4j.api 1.6.2' but it could not be found
      [ERROR] Cannot satisfy dependency: com.liferay.ide.maven.core 2.0.0.qualifier depends on: bundle org.eclipse.m2e.jdt 1.4.0
      [ERROR] Cannot satisfy dependency: org.eclipse.m2e.jdt 1.4.0.20130525-0310 depends on: bundle org.eclipse.m2e.core.ui [1.4.0,1.5.0)

      Attachments

        Activity

          People

            gregory.amerson Gregory Amerson
            gregory.amerson Gregory Amerson
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              9 years, 14 weeks, 1 day ago

              Packages

                Version Package
                2.0.0 M1