Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-1296

Build services doesn't work for new maven service builder project using 6.2.0-ga1 profile

    Details

      Description

      Steps to reproduce:

      1. create new maven service builder project and select a 6.2.0-ga1 profile to add to new project
      2. on service builder portlet project right click and choose "Liferay > Build Services".

      This will fail with the following exception:

      java.lang.IllegalArgumentException: invalid version "6.2.0-ga1": non-numeric "0-ga1"
      at org.osgi.framework.Version.parseInt(Version.java:170)
      at org.osgi.framework.Version.<init>(Version.java:134)
      at com.liferay.ide.maven.ui.MavenProjectAdapter.adapt(MavenProjectAdapter.java:46)
      at com.liferay.ide.project.core.BaseLiferayProject.adapt(BaseLiferayProject.java:45)
      at com.liferay.ide.maven.core.LiferayMavenProject.adapt(LiferayMavenProject.java:56)
      at com.liferay.ide.service.core.job.BuildServiceJob.getProjectBuilder(BuildServiceJob.java:68)
      at com.liferay.ide.service.core.job.BuildServiceJob.runBuild(BuildServiceJob.java:119)
      at com.liferay.ide.service.core.job.BuildServiceJob$1.run(BuildServiceJob.java:101)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2345)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2327)
      at com.liferay.ide.service.core.job.BuildServiceJob.run(BuildServiceJob.java:107)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

        Attachments

          Activity

            People

            Assignee:
            gregory.amerson Gregory Amerson
            Reporter:
            gregory.amerson Gregory Amerson
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              7 years, 3 weeks ago

                Packages

                Version Package
                2.0.0 M3