Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-185

Java classes are not deployed when "Build automatically" is disabled

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.0.1
    • Fix Version/s: None
    • Component/s: Projects > PluginsSDK
    • Labels:
      None

      Description

      Every time you create (or modify) java code, you have to build and then publish the file on servers view.

      Step to reproduce :

      • Check that "Build Automatically" is disabled in eclipse,
      • Create a new Portlet
      • Portlet is deployed and Liferay's log display ERROR [PortletBagFactory:112] java.lang.ClassNotFoundException
      • Build the project

      The .class is generated in project classes folder, but not deployed in tomcat. You have to manually call "publish" on Servers view, or update any file in project.

      => Class update should trigger "publish" features

        Attachments

          Activity

            People

            • Assignee:
              gregory.amerson Gregory Amerson
              Reporter:
              alexist alexis (Inactive)
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                9 years, 49 weeks, 3 days ago

                Packages

                Version Package