Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-232

Server Runtime Setup Fails with Pre-installed Liferay 6.0.5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Component/s: Servers
    • Labels:
      None
    • Environment:
      Win XP, Eclipse Helios (3.6), Liferay CE 6.0.5 w/ Tomcat 6.0.26, Liferay IDE 1.1.0

      Description

      When following the steps to setup the Tomcat Runtime Server (http://www.liferay.com/community/wiki/-/wiki/Main/Liferay+IDE+Getting+Started+Tutorial), I browse to the pre-installed Liferay CE 6.0.5 Tomcat bundle but after selecting the correct Tomcat directory, an error message prohibits me from proceeding.

      Error on top of the screen:
      "Portal version not supported. Need at least 6.02"

      This is incorrect since I have version 6.0.5.

      So as a test, instead of selecting my installation, I chose to 'Download and install..' the displayed option 'liferay-portal-tomcat-6.0.5'. It did download and install; however, it created a directory structure as 'liferay-portal-6.0.3\liferay-portal-6.0.5'. And now I was able to select the Tomcat directory under that structure and proceed with creating the Server.

      So the IDE needs to be able to recognize pre-installed versions above the required 6.0.2 and also not create a dummy directory (6.0.3) that appears to be hardcoded (hack?).

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                8 years, 14 weeks, 3 days ago

                Packages

                Version Package
                1.2