Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-2355

Unable to access bootstrap.jar if server in liferay-workspace is not refreshed.

    Details

      Description

      Hello,

      I have the latest IDE installed in an Eclipse Mars.2.
      I have downloaded the GA1 release (from sourceforge) of the portal and copied it to the bundles folder in my Liferay Workspace.
      I have added the server to the IDE.

      Now when I try to run the server I'm getting the following message:

      The archive: /workspace2/bundles/tomcat-8.0.32/bin/bootstrap.jar which is referenced by the classpath, does not exist.

      (see screenshot 1)

      This seems to be due to the "User Entries" in the classpath for the server's launch configuration (see screenshot 2).

      Unfortunately the "User Entries" settings in the classpath are reset at each "Start the Server" operation so you can't replace them with manual entries and a fully qualified path.

      Is there a workaround for this problem?

      Regards,

      Alex

        Attachments

        1. Archive.zip
          2.09 MB
        2. eclipse.log
          47 kB
        3. screenshot 1.png
          screenshot 1.png
          36 kB
        4. screenshot 2.png
          screenshot 2.png
          105 kB
        5. stacktrace.txt
          78 kB

          Activity

            People

            Assignee:
            simon.jiang Simon Jiang
            Reporter:
            alex.weirig@technolink.lu Alex Weirig
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              4 years, 27 weeks ago

                Packages

                Version Package
                3.0.0