Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-3137

Japanese characters are not saved properly when creating a workflow in Liferay developer studio

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.1.2
    • Component/s: Kaleo Designer
    • Labels:
    • Fix Priority:
      4

      Description

      Description
      Japanese is garbled if create a workflow with "Liferay developer studio"

      Steps to reproduce

      1. Install "liferay-developer-studio-win-x64-3.0.0-ga1-201606202116"(should be Windows OS)
      2. Create a new workspace(e.g. test)
      3. Right click on created workspace > New > Other > Liferay > Liferay Kaleo Workflow > create a new workflow
      4. Drag and drop a task node onto the Workflow Diagram
      5. Right-click the node > Add > Task Action
      6. click on the Task action in the Properties tab and click Edit Task Action (pencil icon)
      7. Input "ワークフロー" > save the workflow
      8. Re-edit the Task Notification

      Actual behavior
      Japanese is garbled.(please refer attaced .png)

      Expected behavior
      Japanese is displayed correctly.

      Note
      This issue happens only in Windows OS. (I used Windows 7 64 bit for testing)
      Not reproduced in OS X.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 11 weeks, 2 days ago

                Packages

                Version Package
                3.1.2