Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-3185

Should not add template to customized package name

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.1 M3
    • Fix Version/s: None
    • Component/s: Modules, Wizards
    • Labels:
      None

      Description

      1. new liferay module project wizard
      2. enter a valid name and choose "api" template > click Next
      3. enter a package name like "com.test" > click Finish
      notice the generated package name is "com.test.api". It should be "com.test"

      All templates which have same problems:
      1. Api
      2. content-targeting-report
      3. content-targeting-rule
      4. content-targeting-tracking-action
      5. control-menu-entry
      6. form-field
      7. mvc-portlet
      8. panel-app(com.test.portlet) I think this might be right. Will check with dev.
      9. portlet
      10. portlet-configuration-icon
      11. portlet-provider(com.test.portlet)
      12. portlet-toolbar-contributor
      13. Rest(com.test.application)
      14. simulation-panel-entry(com.test.application.list)
      15. template-context-contributor

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 18 weeks, 2 days ago

                Packages

                Version Package