Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-3616

It will take a long time to execute gradle task npmInstall for module gradle soy-portlet project in Windows 7 system

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: No Longer Reproducible
    • Affects Version/s: 3.2 M1
    • Fix Version/s: None
    • Component/s: Gradle, Modules
    • Labels:
      None

      Description

      When finish creating gradle soy-portlet project, double click gradle-task: build, it will take a long time to execute npmInstall (i wait for one day).
      I have npm dependency in my home.dir. (C:\Users\liferay\.npm)
      I also check my win10 vm and unbuntu vm, both of them work well.

      Console message:
      Gradle Distribution: Gradle wrapper from target build
      Gradle Version: 3.0
      Java Home: C:\Program Files\Java\jdk1.8.0_151
      JVM Arguments: None
      Program Arguments: None
      Build Scans Enabled: false
      Offline Mode Enabled: false
      Gradle Tasks: build

      :compileJava
      :buildCSS UP-TO-DATE
      :processResources
      :downloadNode
      :downloadMetalCli SKIPPED
      :npmInstallnpm WARN deprecated babel-preset-es2015@6.24.1: 馃檶 Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!
      npm WARN deprecated bower@1.8.2: ...psst! Your project can stop working at any moment because its dependencies can change. Prevent this by migrating to Yarn: https://bower.io/blog/2017/how-to-migrate-away-from-bower/
      npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
      npm WARN deprecated babel-plugin-external-helpers-2@6.3.13: This was a temporary package since the package name was already taken. The package name was transferred for babel so we recommend using babel-plugin-external-helpers instead.
      npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
      npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  1 year, 34 weeks, 2 days ago

                  Packages

                  Version Package