Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-4344

NPE error on server which is create by initbundle again using another url

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4
    • Fix Version/s: 3.5
    • Component/s: Servers
    • Labels:
      None

      Description

      1. new gradle ws and init bundle
      2. change bundle url to something else, for example wildfly and initBundle
      3. open Preferences > server > runtime environment, notice error prompt "Portal version must be greater 7.0"
      4. delete it (uncheck "delete all affected servers")
      5. expand server to check ws exists

      error stack:

      java.lang.NullPointerException
      at com.liferay.ide.gradle.ui.navigator.workspace.LiferayWorkspaceServerContentProvider.getPipelinedChildren(LiferayWorkspaceServerContentProvider.java:76)

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                40 weeks, 4 days ago

                Packages

                Version Package
                3.5