Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-4584

Unable to add Portal Server to Liferay Studio Developer 3.5 with custom context enabled

    Details

    • Type: Story
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.5
    • Fix Version/s: 3.6.1
    • Component/s: Servers > Tomcat
    • Labels:
      None

      Description

      Description

      The customer has found that after changing the portal context to a custom context, they are unable to start the server in Liferay Developer Studio.

      Steps to reproduce

      1. Start Liferay Developer Studio
      2. Create a Liferay Workspace Project and download a DXP 7.1 bundle connected to it
      3. Go to the downloaded bundle and rename tomcat-home/webapps/ROOT to tomcat-home/webapps/sales
      4. Rename tomcat-home/conf/Catalina/localhost/ROOT.xml to tomcat-home/conf/Catalina/localhost/sales.xml
      5. Start Liferay server in Liferay Developer Studio

      Results of Testing

      Expected Results: Liferay server starts
      Actual Results: Liferay server does not start and an error message in the UI appears, saying: Portal version must be greater 7.0

      Errors/Logs - Error in the UI saying "Portal version must be greater 7.0"

      Master

      NA

      Branch

      NA

      * Please see Zendesk Support tab for further comments and attachments.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  25 weeks, 5 days ago

                  Packages

                  Version Package
                  3.6.1