Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-4629

IllegalArgumentException occurs when browse a module with "7.0.LIFERAY-PATCHED-1" in its name in new modules ext wizard

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.6.1
    • Fix Version/s: None
    • Component/s: Modules, Projects > Ext
    • Labels:
      None

      Description

      1. new liferay 7.2 workspace and with Target platform enabled and select index sources
      2. new liferay modules ext project wizard and enter a valid project name
      3. click Browse button in original module name
      4. double click on "asm-analysis:7.0.LIFERAY-PATCHED-1"

      error stack in error log:

      java.lang.IllegalArgumentException: invalid version "7.0.LIFERAY-PATCHED-1": non-numeric "LIFERAY-PATCHED-1"

      at com.liferay.ide.project.ui.modules.ext.ModuleExtArtifactsBrowseActionHandler.browse(ModuleExtArtifactsBrowseActionHandler.java:56)

      at com.liferay.ide.project.ui.action.NewWizardAction.run(NewWizardAction.java:117)

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                6 weeks, 3 days ago

                Packages

                Version Package