Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-4666

Failed to remove dependency versions when build file contains other configurations except for dependencies

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.6.2
    • Fix Version/s: 3.7 GA1
    • Component/s: Upgrade Planner
    • Labels:
      None

      Description

      1. new liferay workspace 70 and create a module project, add the following code into project's build.gradle 
        FileTree soyJsFileTree = fileTree(dir: "classes", include: "**/*.soy.js")
      1. new liferay upgrade plan > select code upgrade outline
      2. Upgrade Build Dependencies > Remove Dependency Versions > click Perform

      error stack:

      An internal error occurred during: "Performing Remove Dependency Versions...".

      at com.liferay.ide.gradle.core.parser.GradleDependencyUpdater.<init>(GradleDependencyUpdater.java:57)at com.liferay.ide.gradle.core.parser.GradleDependencyUpdater.<init>(GradleDependencyUpdater.java:57) at com.liferay.ide.gradle.core.parser.GradleDependencyUpdater.<init>(GradleDependencyUpdater.java:43) at com.liferay.ide.gradle.ui.upgrade.RemoveDependencyVersionCommand._removeDependencyVersion(RemoveDependencyVersionCommand.java:103)

      com.liferay.ide.gradle.ui.upgrade.RemoveDependencyVersionCommand.perform(RemoveDependencyVersionCommand.java:64) at com.liferay.ide.gradle.ui.upgrade.RemoveDependencyVersionCommand.perform(RemoveDependencyVersionCommand.java:64) at com.liferay.ide.upgrade.plan.ui.internal.steps.UpgradeStepItem._perform(UpgradeStepItem.java:286) at com.liferay.ide.upgrade.plan.ui.internal.steps.UpgradeItem$1$1.run(UpgradeItem.java:67)

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 weeks, 1 day ago

                  Packages

                  Version Package
                  3.7 GA1