PUBLIC - Liferay IDE
  1. PUBLIC - Liferay IDE
  2. IDE-617

Switch build-sapphire.xml to use tycho annotation processor support

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Releng > Build
    • Labels:
      None
    • Similar Issues:
      Show 5 results 

      Activity

      Gregory Amerson added a comment -

      More information
      Fellow community members,

      for those interested in annotation processing support for m2e, I've released m2e-apt 1.0.0 [0], based on Karl M. Davis [1] and St├ęphane Landelle [2] prior work on the subject.
      You can find more details here [3].

      [0] http://download.jboss.org/jbosstools/updates/m2e-extensions/m2e-apt
      [1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=335036
      [2] https://github.com/excilys/m2e-extras/tree/master/com.excilys.ebi.m2e.apt
      [3] https://community.jboss.org/en/tools/blog/2012/05/20/annotation-processing-support-in-m2e-or-m2e-apt-100-is-out

      Gregory Amerson added a comment -

      Doesn't appear ready for main-stream until sapphire can support 1.6 annotation processor.

      Gregory Amerson added a comment -

      Will just wait until sapphire 0.7 and the @GenerateImpl is going away.

      Yanan Yuan added a comment -

      No need to regression test for this.


        People

        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:
            Date of First Response:
            Days since last comment:
            48 weeks, 5 days ago

            Development

              Structure Helper Panel