Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-634

As a liferay plugin developer, I would like the ability to develop with a Liferay runtime bundled with tomcat of non-standard version

    Details

    • Type: Story
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: Servers, Servers > Tomcat
    • Labels:
      None

      Description

      I want to have a workspace with 6.1.x and 6.0.x, it would be good to support that. Look here:

      https://github.com/liferay/liferay-ide/blob/master/eclipse/server/plugins/com.liferay.ide.eclipse.server.tomcat.core/src/com/liferay/ide/eclipse/server/tomcat/core/LiferayTomcatRuntime70.java

      The problem is that Liferay Portal Runtimes for 6.1 assume Tomcat 7, but it is possible for it to target Tomcat 6. Also, it is possible that Liferay 6.0.x runtimes can target Tomcat 7. The runtime/server adapters should relax the requirement for tomcat6/7 if possible.

        Attachments

          Activity

            People

            Assignee:
            lr_studio LR Studio
            Reporter:
            armin.dahncke Armin Dahncke
            Participants of an Issue:
            Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 14 weeks, 6 days ago

                Packages

                Version Package