Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-887

As a liferay ide user, if I create a new plugin that already exists in my plugins sdk, there should be better error messages or conflict resolution to prevent this

    Details

    • Type: Story
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 2.0.0 M1
    • Component/s: Wizards, Wizards > Project
    • Labels:
      None

      Description

      If a user tries to create a plugin project of type portlet called "new", and "new-portlet" already exists on the system, LiferayIDE will silently fail and create the project incorrectly as "new".

      LiferayIDE should explicitly prevent the user from creating a plugin (of any type) if it already exists in their plugins SDK. Ideally, it would provide some type of conflict resolution where the user is not required to manually delete the portlet from their plugins SDK before they're allowed to create it. Or maybe Studio just provides a descriptive message informing the user where to delete the folder. (I have no preference on how the conflict resolution part should work but am available to provide input if that helps.)

        Attachments

          Activity

            People

            Assignee:
            gregory.amerson Gregory Amerson
            Reporter:
            edward.shin Edward Shin (Inactive)
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              7 years, 41 weeks, 1 day ago

                Packages

                Version Package
                2.0.0 M1