Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-920

Cannot find org.eclipse.m2e.core 1.4.0 dependency

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.0.0
    • 2.0.0 M1
    • Releng > Build
    • None
    • Jenkins( build-1:9090)

    Description

      [INFO] Cannot complete the request. Generating details.
      [INFO] Cannot complete the request. Generating details.
      [INFO]

      {osgi.ws=win32, osgi.os=win32, osgi.arch=x86_64, org.eclipse.update.install.features=true}

      [ERROR] Cannot resolve project dependencies:
      [ERROR] Software being installed: com.liferay.ide.maven.core 2.0.0.qualifier
      [ERROR] Missing requirement: com.liferay.ide.maven.core 2.0.0.qualifier requires 'bundle org.eclipse.m2e.core 1.4.0' but it could not be found
      mavenExecutionResult exceptions not empty[ERROR]

      message : Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from com.liferay.ide.maven.core 2.0.0.qualifier to bundle org.eclipse.m2e.core 1.4.0.", "Unable to satisfy dependency from com.liferay.ide.maven.core 2.0.0.qualifier to bundle org.eclipse.m2e.jdt 1.4.0.", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "No solution found because the problem is unsatisfiable."]
      cause : "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from com.liferay.ide.maven.core 2.0.0.qualifier to bundle org.eclipse.m2e.core 1.4.0.", "Unable to satisfy dependency from com.liferay.ide.maven.core 2.0.0.qualifier to bundle org.eclipse.m2e.jdt 1.4.0.", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "No solution found because the problem is unsatisfiable."]

      Attachments

        Activity

          People

            gregory.amerson Gregory Amerson
            yanan.yuan Yanan Yuan(Ashley Yuan)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              9 years, 24 weeks, 5 days ago

              Packages

                Version Package
                2.0.0 M1