Uploaded image for project: 'PUBLIC - Liferay IDE'
  1. PUBLIC - Liferay IDE
  2. IDE-956

No 'build-lang', 'compile-test', 'test' targets should show popupmen for projects based in SDK less than 6.1

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0 M2
    • Component/s: Projects > PluginsSDK
    • Labels:
      None
    • Environment:
      Liferay IDE 2.0.0.20130517-0553
      liferay-plugins-sdk-6.0.6-20110225
      liferay-portal-6.0.6

      Description

      1.Create a liferay portlet prject.
      2.Right click this project, choose Liferay> SDK >build-lang
      In the Console, it will show BUILD FAILED Target "build-lang" does not exist in the project "XXX".
      The same as Liferay > SDK >compile-test and Liferay > SDK > test.
      Open the build-common-plugin.xml file you'll see there is no 'build-lang', 'compile-test' and 'test' these three targets in this file.

        Attachments

        1. build-common-plugin.xml
          20 kB
        2. build-lang.JPG
          build-lang.JPG
          57 kB
        3. compile-test.JPG
          compile-test.JPG
          64 kB
        4. test.JPG
          test.JPG
          62 kB

          Activity

            People

            Assignee:
            tao.tao Tao Tao (Inactive)
            Reporter:
            vicky.wang Vicky Wang (Inactive)
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              6 years, 11 weeks, 6 days ago

                Packages

                Version Package
                2.0.0 M2