Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Reorganized
    • Affects Version/s: 5.1.0
    • Fix Version/s: 5.1.1, 5.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Liferay 5.1.0, Websphere 6.1
    • Similar Issues:
      Show 5 results 

      Description

      The portal.properties file located in portal-impl.jar is not loaded because of the following exception:

      [21/07/08 15.25.10:796 PDT] 00000032 SystemOut O 15:25:10,531 ERROR [ContextLoader:220] Context initialization failed
      java.lang.ExceptionInInitializerError
      at java.lang.J9VMInternals.initialize(J9VMInternals.java:195)
      at com.liferay.portal.spring.context.PortalApplicationContext.loadBeanDefinitions(PortalApplicationContext.java:65)
      at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92)
      ...
      Caused by: com.germinus.easyconf.ConfigurationNotFoundException: Error reading configuration for file:/C:/Program Files/IBM/WebSphere/AppServer/profiles/AppSrv01/installedApps/iassvilCell01/liferay-portal-5_1_0_WAS601_war.ear/liferay-portal-5.1.0_WAS601.war/WEB-INF/lib/portal-impl.jar!/portal: The base properties file was not found
      at com.germinus.easyconf.ComponentConfiguration.getProperties(ComponentConfiguration.java:143)
      at com.liferay.portal.configuration.ConfigurationImpl.getComponentProperties(ConfigurationImpl.java:245)
      at com.liferay.portal.configuration.ConfigurationImpl.printSources(ConfigurationImpl.java:288)

      I guess the problem is that under Websphere the line

      URL url = classLoader.getResource(name + ".properties");

      #260 in com.liferay.portal.configuration.ConfigurationImpl returns "wsjar" instead of "jar" as the URL protocol.

        Issue Links

          Activity

          Hervé Ménage added a comment - - Restricted to

          Same error on my WAS 6.1 installation
          Hervé

          Rich Sezov added a comment - - Restricted to

          WebLogic 10 also has the same problem.

          Rich Sezov added a comment - - Restricted to

          Committed to SVN.

          Brian Chan added a comment -

          Thanks Rich.

          Thomas Fromm added a comment -

          In JBoss 6, the protocol is "vfs". So the deployment fails (at least with LR 5.2.3).

          Rich Sezov added a comment -

          Hello Thomas,

          This project is no longer used, and has been migrated into the LPS project. For that reason, I'm going to close this ticket. Can you open a ticket in the LPS project which references this one? Then you should get visibility on it.

          Thanks!

          --Rich

          Rich Sezov added a comment -

          Asked reporter to open a ticket in the active project.


            People

            • Assignee:
              Rich Sezov
              Reporter:
              Lorenzo Zimolo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Structure Helper Panel