Uploaded image for project: 'PUBLIC - Liferay Portal Enterprise Edition'
  1. PUBLIC - Liferay Portal Enterprise Edition
  2. LPE-10824

HTML field for a Web Content Structure cannt have a name a with hyphen

    Details

      Description

      Steps to reproduce this issue:
      1. On the Dockbar, navigate to Admin > Site Administration > Content.
      2. In the displayed Web Content page, navigate to Manage > Structures.
      3. Click Add, enter ‘Test Structure’ as the structure’s name and drag an HTML field into the grey area on the right.
      4. Configure the added HTML field, enter ‘test-name’ as the value of its Name property, and then click Save to create a new structure.
      5. Go back to the Web Content page mentioned in step 2 and click ‘Test Structure’ in the Add drop-down list.
      Excepted result: Should be able to add web content with structure test-name
      Actual result: You can not add a web content with structure with test-name and whole js will display on the end.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                andrew.betts Andrew Betts
                Reporter:
                eric.min Eric Min (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Packages

                  Version Package
                  6.2.X EE