Uploaded image for project: 'PUBLIC - Liferay Portal Enterprise Edition'
  1. PUBLIC - Liferay Portal Enterprise Edition
  2. LPE-6995

Organization admins of non root organization encounter errors when redirected to root orgainzation when utilizing "back" link through the 'Organizations and Users' portlet.

    Details

    • Fix Pack Status:
      Scheduled

      Description

      1. Login to liferay.
      2. Create 2 organizations.
      3. Make one the child of the other.
      4. In the child organization, create a new user and assign them the Organization Admin role.
      5. Sign in as the user from step 4.
      6. Go to Control Panel-> Users and Organizations.
      7. Under "Search All Organizations" click on the organization
      7. Click on the "Back to (parent organization)" link

      Tomcat should populate the error log from the customers attached document. I was able to replicate the exact error in my tomcat.
      I suspect that this is a permissions issue and is working as intended, because the link redirects the user to an organization they lack admin privileges to.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              angelo.jefferson Angelo Jefferson
              Reporter:
              sherry.yang Sherry Yang (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Due:
                Created:
                Updated:
                Resolved:

                  Packages

                  Version Package
                  6.1 EE GA1 (6.1.10)