Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-100425

[$SITE_NAME$] is resolved incorrectly for Message Boards on 7.0.x

    Details

      Description

      Steps to Reproduce

      1. Set up the mail sender in Server Administration
      2. Go to Contents > Message Boards > option menu > Configuration > Message Added Email
      3. Replace the body with [$SITE_NAME$] and save
      4. Add the Message Boards portlet to a page
      5. Subscribe to the board
      6. Add a new thread
      7. Check the email sent

      Actual results
      [$SITE_NAME$] is resolved as "Message Boards Home - Liferay"

      Expected results
      [$SITE_NAME$] is resolved as "Liferay"

      Note
      This issue affects 7.0.x only. The string "Message Boards Home" was added by LPS-68589. When Message Boards was refactored to a module (LPS-69934 and LPS-76509) this string was dropped. Currently in Master [$SITE_NAME$] resolves to simply the site name with no added string in front. This unique fix will make 7.0.x mirror later versions.

        Attachments

          Activity

            People

            • Assignee:
              jeremy.chen Jeremy Chen
              Reporter:
              jonathan.mccann Jonathan McCann
              Participants of an Issue:
              Recent user:
              Clarissa Velazquez
              Engineering Assignee:
              Jonathan McCann
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 weeks, 6 days ago

                Packages

                Version Package
                7.0.0 DXP FP86
                7.0.X