Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-101407

A slash "/" is added at the end of site URL when no locale prepended

Details

    • Bug
    • Status: Closed
    • Resolution: Won't Fix
    • 7.2.X, Master
    • None
    • None
    • 3
    • Regression Bug

    Description

      Steps to reproduce:

      1. Add a blank site, Site Name
      2. Add a public page to the site, Site Page Name
      3. Go to added site's Configuration > Settings
      4. Choose Define a custom default language and additional available languages for this site, configure the Default Language to Spanish (Spain)
      5. Navigate to http://localhost:8080/web/site-name
      6. Append es to the URL, http://localhost:8080/es/web/site-name
      7. Click the Display the page in English (United States) link in the pop up message

      Actual result:
      A slash "/" is added at the end of site URL, the URL is http://localhost:8080/web/site-name/.

      Expected result:
      No slash "/" is added at the end of site URL, the URL is http://localhost:8080/web/site-name.

      Attachments

        Issue Links

          Activity

            People

              lu.liu Lu Liu
              lu.liu Lu Liu
              Marta Elicegui Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                3 years, 11 weeks, 3 days ago

                Packages

                  Version Package