Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-102403

In Spanish language site, can not add web content with another language

    Details

      Description

      Steps to reproduce:

      1. Add a new site
      2. Add a es_ES localized site name: Nombre del Sitio
      3. Add a new page
      4. Go to Configuration > Settings > Languages
      5. Remove all available languages except Spain and German
      6. Set Default Language to Spain
      7. Go to Web content, add a new web content with English

      Expected Result:
      Can add a web content

      Actual Result:
      Can not add a web content, no matter what language you used, the error message is:

      Error: The default language (en_US) does not match the portal's available languages (es_ES, de_DE).
      

      even use Spanish.

        Attachments

        1. EN.PNG
          EN.PNG
          75 kB
        2. ES.PNG
          ES.PNG
          75 kB
        3. ZH.PNG
          ZH.PNG
          82 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  10 weeks ago

                  Packages

                  Version Package
                  7.2.10 DXP FP2
                  7.2.10.1 DXP SP1
                  7.2.X
                  7.2.1 CE GA2
                  Master