Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-102714

Valid values are not validated correctly when importing a fragment

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: Master
    • Component/s: WCM > Fragments
    • Labels:
      None

      Description

      Steps to reproduce

      • Create a fragment with the following configuration:
        • {
            "fieldSets": [
              {
                "label": "marco",
                "fields": [
                  {
                    "name": "ola",
                    "type": "select",
                    "typeOptions": {
                      "validValues": ["dark", "light"]
                    },
                    "defaultValue": "dark"
                  }
                ]
              }
            ]
          }
          
          
      • Import this fragment in a content page
      • Reload the page

      Expected result

      The fragment cannot be published because the configuration is wrong

      Actual result

      The fragment is imported correctly and it breaks the page if it is added

       

       

        Attachments

          Activity

            People

            • Assignee:
              yang.cao Yang Cao
              Reporter:
              victor.galan Victor Galan
              Participants of an Issue:
              Recent user:
              Yang Cao
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                9 weeks, 5 days ago

                Packages

                Version Package
                Master