Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.1.2
    • Fix Version/s: 5.2.0
    • Component/s: None
    • Labels:
      None
    • Backported to Branch:
      Committed
    • Liferay Contributor's Agreement:
      Accept

      Description

      When save a configuration setup and try to restore to those settings using these steps many things disappear.

      1) Clear cache. Delete 'home'. 'rebuild-mysql'.
      2) Open 'tomcat-5.5.27'.
      3) Go to 'http://localhost:8080'.
      4) Go to 'my-community-private-page'.

      5) Add a page. (You can name it 'test')
      6) Add a 'Blogs' portlet to the page you just created.
      7) Add an entry.
      8) Add another page. (You can name it 'asset')
      9) Add the 'Asset Publisher' portlet to the page you just created.

      10) Click 'Configuration'.
      11) Go to the 'Display Settings'. Change the 'Display Style' from 'Abstract' to 'Full Content'.
      12) Click 'Save'.
      13) Go to the 'Display Settings'. Change the 'Display Style' back to 'Abstract'.
      15) Click 'Save'.
      16) Go to the 'Archived' tab. Create an archived setup. (You can name it 'test')
      17) Click 'Save'.
      18) Change the 'Asset Selection' from 'Dynamic' to 'Manual'.
      19) Click on 'Select Existing..' then chose 'Blogs Entry'. Select the entry that you made earlier.
      20) Go to the 'Display Settings'. Change the 'Display Style' from 'Abstract' to 'Full Content'.
      21) Click 'Save'.
      22) Go to the 'Archived' tab. And revert back to the archived setup that you created earlier.

      *If you go back to the 'Current' tab. There will be nothing*
      *If you click 'Return to Full Page'. There will also be nothing*
      *Also after you try viewing one of those things the tomcat window will show an error*

        Issue Links

          Activity

          michael.hashimoto Michael Hashimoto added a comment -

          This is the error that shows up on the tomcat window.

          jorge.ferrer Jorge Ferrer added a comment - - Restricted to

          Wow, I'm surprised you were able to catch that one, it's not so easy to reproduce.

          Nice Job, Michael!

          jorge.ferrer Jorge Ferrer added a comment -

          Fix committed to trunk


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                8 years, 15 weeks, 3 days ago

                Development

                  Subcomponents