Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-103383

7.2 Content Pages do not show Web Content when using Staging with Page Versioning

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.2.X, Master
    • Fix Version/s: Master
    • Component/s: WCM > Fragments
    • Labels:
    • Fix Priority:
      3

      Description

      In 7.2, Web Content does not properly appear on a Content Page when using Staging with Page Versioning.

      It seems the Web Content Display's portlet preferences are not being propagated to the versioned page.

      Steps to Reproduce

      1. Setup Staging with Page Versioning enabled
      2. Navigate to the Staging Site
      3. Create a Web Content
      4. Navigate to Site Builder > Pages
      5. Create a Content Page
        1. Add a Web Content Display and configure it to display the created Web Content
        2. Publish the Content Page
      6. Navigate to the actual Content Page on the site

      Expected Behavior
      The Web Content's title and content are displayed.

      Actual Behavior
      The page is blank and does not show the Web Content's title and content.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                support-lep@liferay.com SE Support
                Reporter:
                eric.yan Eric Yan
                Participants of an Issue:
                Recent user:
                Eric Yan
                Engineering Assignee:
                Eric Yan
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  14 weeks ago

                  Packages

                  Version Package
                  Master