Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-103435

Startup error: Could not resolve module: com.liferay.lcs.client.web

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: Master
    • Fix Version/s: None
    • Component/s: Core Infrastructure
    • Labels:
      None
    • Fix Priority:
      5

      Description

      Steps to reproduce:

      1. Start up master-private bundle

      Actual Result:

        [exec] 02:50:26,379 ERROR [Framework Event Dispatcher: Equinox Container: 31999360-3605-4f84-8df2-2dd442ca4c6e][Framework:93] FrameworkEvent ERROR 
           [exec] org.osgi.framework.BundleException: Could not resolve module: com.liferay.lcs.client.web [341]
           [exec]   Unresolved requirement: Import-Package: com.liferay.portal.kernel.language; version="[7.0.0,8.0.0)"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
           [exec] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
           [exec] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
           [exec] 02:50:26,380 ERROR [Framework Event Dispatcher: Equinox Container: 31999360-3605-4f84-8df2-2dd442ca4c6e][Framework:108] Exiting the JVM 
           [exec] org.osgi.framework.BundleException: Could not resolve module: com.liferay.lcs.client.web [341]
           [exec]   Unresolved requirement: Import-Package: com.liferay.portal.kernel.language; version="[7.0.0,8.0.0)"
           [exec] 
           [exec] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
           [exec] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
           [exec] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
           [exec] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
         [delete] Deleting: /opt/dev/projects/github/liferay-portal-master-private/jps_output
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                victor.ware Victor Ware
                Reporter:
                linda.sui Linda Sui
                Participants of an Issue:
                Recent user:
                Della Wang
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 weeks ago

                  Packages

                  Version Package