Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-103558

Rule for Keywords doesn't work when selecting content set in AP

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: Master
    • Component/s: Asset Lists
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Create the following web contents
        Article Name Content
        wc1 one
        wc12 one two
        wc123 one two three
        wc1234 one two three four
        wc234 two three four
        wc34 three four
        wc4 four
      2. Go to Content & Data > Content Sets
      3. Click New > dynamic section > input a name and save
      4. In filter section, select Contains, select Any, select Keywords, input two three for Keywords
      5. Add an asset publisher to page
      6. In Asset selection, select Content Set
      7. Under Select Content Set, select the one added in step 3, save the configuration
      8. Assert only wc12,wc123,wc1234,wc234,wc34 display

      Actual result:
      All the web contents display.

      Expected result:
      Only wc12,wc123,wc1234,wc234,wc34 display.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  3 weeks, 5 days ago

                  Packages

                  Version Package
                  Master