Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-104677

Editable fields in content pages revert to default values in edit mode after upgrading from 7.1

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: Master
    • Fix Version/s: Master
    • Component/s: WCM

      Description

      Steps to reproduce:

      • Start 7.1
      • Create a new fragment collection
      • Create a new fragment with and editable field of type image and type text (ie: <lfr-editable type="rich=text" id="tx001"> some test</lfr-editable)
      • Create a new content page and add the fragments to it
      • Change the default text of those fragments
      • Stop 7.1 and upgrade to master
      • Start master
      • Click on the page that was created (it should show OK)
      • Click on the pencil on the top to go to edit mode

      Expected result: The page is shown correctly with the new values as in view mode

      Actual result: The page shows the default values of the editables. Also, a lot of errors are thrown in the web console

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yang.cao Yang Cao
                Reporter:
                jurgen.kappler Jürgen Kappler
                Participants of an Issue:
                Recent user:
                Yang Cao
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 days ago

                  Packages

                  Version Package
                  Master