Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-105567

lpkg-independence, lpkg-release, and lpkg-base failing with unresolved requirements

    Details

      Description

      lpkg-independence:

          [junit] 12:05:58,729 ERROR [Framework Event Dispatcher: Equinox Container: 9572be8b-cdfd-4d48-8ca9-70c884051b04][Framework:93] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.trash.web [79]
          [junit]   Unresolved requirement: Import-Package: com.liferay.depot.application; version="[1.0.0,2.0.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      

      lpkg-release:

          [junit] 12:16:09,928 ERROR [Framework Event Dispatcher: Equinox Container: 6bcd0e36-be54-4f50-85ea-e47026b6dcae][Framework:93] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.asset.categories.admin.web [351]
          [junit]   Unresolved requirement: Import-Package: com.liferay.depot.application; version="[1.0.0,2.0.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      

      lpkg-base:

          [junit] 12:35:02,874 ERROR [Framework Event Dispatcher: Equinox Container: 57b4b69e-ec79-4b6e-8bea-4c54d3e579a8][Framework:93] FrameworkEvent ERROR 
          [junit] org.osgi.framework.BundleException: Could not resolve module: com.liferay.trash.web [231]
          [junit]   Unresolved requirement: Import-Package: com.liferay.depot.application; version="[1.0.0,2.0.0)"
          [junit] 
          [junit] 	at org.eclipse.osgi.container.Module.start(Module.java:444)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1662)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
          [junit] 	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
          [junit] 	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  32 weeks, 4 days ago

                  Packages

                  Version Package
                  7.3.0 CE GA1
                  Master