Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-106300

Search Scope `Everything` not returning results from other sites on default search page

Details

    Description

      Steps to reproduce:

      1. Create a new site called "New Site"
      2. Within New Site, create a web content article titled "web content"
      3. Navigate back to default Liferay site
      4. Navigate to configuration for the embedded home page search bar
      5. Change scope to "Everything"
      6. Search for "web content" within embedded search bar
      7. On the default search page, change the configuration Scope to Everything for the in-page Search Bar widget
      8. Search for "web content" within the in-page Search Bar widget

      Expected result: For both searches, the "web content" asset that was created on "New Site" should be returned in the search results.

      Actual result: "web content" is not returned in either search results.

      Note: This is NOT reproducible when searching via the Search Bar + Search Results widgets that a user manually adds to the page themselves. It only happens for the default search bar template page.

      Reproduced on:
      Portal master git commit: 41fa17c73020f6e6fa3c4a597a687afd788f41c4

      Attachments

        Issue Links

          Activity

            People

              linda.sui Linda Sui
              joshua.chong Joshua Chong
              Marta Elicegui Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                2 years, 47 weeks, 2 days ago

                Packages

                  Version Package
                  7.3.0 CE GA1
                  7.3.10 DXP GA1
                  Master