Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-108033

Cluster test shows number of nodes connected to ElasticSearch is 1

    Details

      Description

      Steps to reproduce:
      1. Set property "cluster.link.enabled=true" (portal-ext)
      2. Set database connection properties (HSQL not supported)
      3. Create config file
      osgi/configs/com.liferay.portal.store.file.system.configuration.FileSystemStoreConfiguration.config
      4. Set config inside of new file
           -     rootDir="/Users/username/liferay/master-bundle-1/data/document_library"
      5. Make a copy of the tomcat bundle in a new location (all configs should be the same)
      6. Set second bundle port to 9080
            -     sed -i "s/8005/9005/; s/8080/9080/; s/8009/9009/; s/8443/9443/g" ../conf/server.xml
      7. Start first Portal server
      8. Start second Portal
      9. Navigate to http://IP:PORT/_cluster/health?pretty
      10. Assert there are 2 nodes in the cluster

      Expected Results:
      Cluster health shows two nodes running

      Actual Results:
      Number of nodes is 1

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                26 weeks, 5 days ago

                Packages

                Version Package