Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-110434

Compile failed on spring mvc portlet project in gradle workspace

    Details

      Description

      Blade: blade version 3.9.1.202002251825

      all kinds of spring mvc portlet projects. For example:

      1. blade init -v 7.3 
      2. blade create -t spring-mvc-portlet -v 7.3 --framework springportletmvc --framework-dependencies Embedded --view-type jsp test
      3. cd to wars/test and execute gw build. 

      notice :wars:test:compileJava FAILED

      To reslove the compile error, we need to add some dependencies' versions compared to gradle standalone spring-mvc-portlet

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  11 weeks, 3 days ago

                  Packages

                  Version Package
                  7.0.4 CE GA5
                  7.1.3 CE GA4
                  7.2.1 CE GA2
                  7.3.0 CE GA1
                  7.3.1 CE GA2
                  7.3.2 CE GA3