Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-11231

Delete from portlet before importing has inconsistent behavior with different portlets

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.3 GA
    • Fix Version/s: 6.0.3 GA
    • Component/s: Staging
    • Labels:
      None
    • Environment:
      Trunk 58246

      Description

      I tested with a couple portlets, and here are the results when I selected "Delete from portlet before importing" when Publishing to Live. In both tests, I created a folder and created an entry inside the folder. I also created an entry that belonged to no folder.

      Bookmarks Portlet
      Deleted my folders and links within the folder in staging and live page, but did not delete the link without a folder.

      document library
      Did not delete my folders or file without a folder in staging.
      Deleted the folder in live, but did not delete the file without a folder.

      I suspect that the behaviors may be different depending on each portlet. What should the expected behavior be, and should they be consistent across all portlets?

        Attachments

          Activity

            People

            • Assignee:
              raymond.auge Raymond Auge
              Reporter:
              ivan.cheung Ivan Cheung
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                10 years, 5 weeks, 4 days ago

                Packages

                Version Package
                6.0.3 GA