Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-112650

ARIA attributes doesn't have valid values in form creating panel

    Details

    • Type: Bug
    • Status: Verified
    • Resolution: Unresolved
    • Affects Version/s: 7.2.1 CE GA2
    • Fix Version/s: None
    • Component/s: Forms
    • Labels:
      None
    • Fix Priority:
      1

      Description

      Actual result:
      Marked elements on screenshot have invalid aria-controls and other aria-* attributes. For example aria-controls attribute links to the same id (which doesn't exist) for buttons Elements and Element Sets in Add Elements sidebar.

      <a class="nav-link active" aria-controls="sidebarLightDetails" data-toggle="tab" href="javascript:;" role="tab"><span class="navbar-text-truncate">Elements</span></a>
      ...
      <li class="nav-item" data-index="0" ref="tab0"><a class="nav-link active" aria-controls="sidebarLightDetails" data-toggle="tab" href="javascript:;" role="tab"><span class="navbar-text-truncate">Elements</span></a></li>
      

      Expected result:
      Correct values for ARIA attributes. Page valid with WCAG and W3C validator.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              support-lep@liferay.com SE Support
              Reporter:
              marcin.p90 Marcin Pawluk
              Participants of an Issue:
              Recent user:
              Cleyton Magalhaes (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Days since last comment:
                34 weeks, 3 days ago

                  Packages

                  Version Package