Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-113726

Friendly error messages are not being displayed

    Description

    Preconditions

    1. N/A

    Steps to Reproduce

    1. Go to Control Panel > Workflow > Process Builder > Plus icon button
    2. Remove the connector and the start node
    3. Try to publish it

    Actual Result

    A generic error message is displayed

    Expected Result

    "You must define a start node." error message should be displayed

    This is also reproducible for all other friendly error messages:
    "The workflow has too many start nodes (state nodes StartNode and TestStartNode)."
    "The StartNode node must have an outgoing transition."
    "The Start node cannot have an incoming transition."
    "The Condition node must have at least two outgoing transitions."
    "Each fork node requires a join node. Make sure all forks and joins are properly paired."

    Reproduced In
    master: 642170d14e4b3a7a6937d524c794cb8d856c30ae

      Attachments

        Activity

          People

          • Assignee:
            rodrigo.cunha Rodrigo Cunha
            Reporter:
            rodrigo.cunha Rodrigo Cunha
            Participants of an Issue:
            Recent user:
            Jason Pince
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              11 weeks, 1 day ago

              Packages

              Version Package
              7.3.3 CE GA4
              Master