Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-114323

Escaped HTML entities and HTML tags visible in Message Board reply

    Details

    • Type: Task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Message Boards
    • Labels:
      None

      Description

      To make this reply: https://liferay.dev/forums/-/message_boards/view_message/119237519

      I selected "Reply with Quote" from the menu, typed my response without applying any formatting or markup, and submitted.

      End result shows visible escaped HTML entities (eg. for apostrophes) and tags (eg. <p>).

      Also, there's no quote in the reply; I would make a separate ticket for that, but starting with this issue first because it seems more obviously bad (because everyone reading the post will see it, unlike the failure to include a quote, which only I as the author see).

        Attachments

          Activity

            People

            Assignee:
            support-lep@liferay.com SE Support
            Reporter:
            greg.hurrell Greg Hurrell
            Recent user:
            Greg Hurrell
            Participants of an Issue:
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:

                Packages

                Version Package