Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-116189

NPE when deploying a react plugin due to corrupt version number

    Details

    • Branch Version/s:
      7.2.x

      Description

      Issue
      NPE when deploying a plugin due to corrupt version number

      Steps to reproduce
      1. Create a sample react plugin

      blade create -t npm-react-portlet test-react

      2. Install a new module

      cd test-react
      npm install --save --save-exact [email protected]

      3. Deploy the sample plugin

      blade gw deploy

      Expected results
      Plugin is deployed successfully*

      Actual results
      NPE is thrown and plugin is not deployed

      Reproduced in
      7.2 dxp-6
      7.2.x (f86302d6490c77cb0cddc0c042a14c9c6e4131aa)

      * Please see Zendesk Support tab for further comments and attachments.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              to.trinh To To Trinh
              Reporter:
              to.trinh To To Trinh
              Participants of an Issue:
              Recent user:
              To To Trinh
              Engineering Assignee:
              To To Trinh
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 23 weeks, 6 days ago

                  Packages

                  Version Package
                  7.2.X