Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-11622

Removing of asset (for example blog entry) is not updated AssetTag statistics, as result tag cloud display incorrect info

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.4 GA
    • Fix Version/s: 6.0.4 GA, 6.0.5 GA
    • Component/s: WCM
    • Labels:
      None
    • Environment:
      Liferay 6.0.4 bundled with tomcat

      Description

      To replroduce bug:
      1. place tag cloud and and blogs portlets on same page
      2. Create some blog items with tags
      3. Remove blog items

      Tag Cloud still displayed tags what do not have any assets.

      I think it happens because BlogsEntryLocalServiceUtil.deleteEntry called only assetEntryLocalService.deleteEntry - but this method only removed AssetEntry itself - not updating AssetTags statistics

        Attachments

          Activity

            People

            • Assignee:
              jonathan.potter Jonathan Potter (Inactive)
              Reporter:
              akakunin Alexey Kakunin
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                9 years, 20 weeks, 1 day ago

                Packages

                Version Package
                6.0.4 GA
                6.0.5 GA