Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-116688

Fragment Editor preview doesn't show animated JQuery animation with bootstrap

    Details

    • Fix Priority:
      4

      Description

      When using bootstrap code with animation example: https://getbootstrap.com/docs/4.0/components/navbar/#supported-content

      Expected:

      I'm expecting to have :

      1/ The responsive behavior of bootstrap with toggle Button

      2/ The animation of the NavBar menu to become vertical instead of horizontal.

      However after activating JQuery in Configuration > Settings > ThirdParty 

       

      The current result:

      When clicking on the Button of my NavBar when viewing the fragment with mobile viewport or using the fragment CLI. The animation of the menu doesn't work. It is impossible to see the menu items.

      Steps:

      1/ Activate JQuery in Site

      2/ Create new fragment using fragment editor or fragment toolkit.

      3/ Preview the Fragment using both tools

      4/ Resize to mobile viewport

      5/ Click on the Button to toggle vertical menu animation

      6/ Fails

        Attachments

          Activity

            People

            • Assignee:
              victor.galan Victor Galan
              Reporter:
              tarik.demnati Tarik Demnati
              Participants of an Issue:
              Recent user:
              Victor Galan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                4 weeks, 3 days ago

                Packages

                Version Package